Урок информатики по теме "Условная функция в табличном процессоре Excel". 9-й класс

Разделы: Информатика


Цель урока: освоение учащимися общего вида и правил выполнения условной функции, обучение применению ее при решении задач; повторение логических выражений и изучение особенностей записи логических выражений в электронных таблицах.

Оборудование: компьютеры; программное обеспечение, индивидуальные карточки с заданиями.

Презентация

План урока

I. Орг.момент

II. Проверка домашнего задания

http://school-collection.edu.ru/catalog/rubr/8f5d7210-86a6-11da-a72b-0800200c9a66/19661/

(Cлайд 2)

III. Изучение нового материала

- Ребята, давайте мы с вами решим задачу с использованием табличного процессора MS Excel.

(Cлайд 3)

Задача. Разработать таблицу, содержащую следующую информацию об абитуриентах: фамилия, оценки за экзамены по математике, русскому и иностранному языкам, сумма баллов за три экзамена и информацию о зачислении: если сумма баллов больше или равна проходному баллу и оценка за экзамен по математике – 4 или 5, то абитуриент зачислен в учебное заведение, в противном случае – нет.

- Исходной информацией являются фамилии, оценки за экзамены и проходной балл. Сумма баллов и информация о зачислении вычисляются с помощью формул.

(Учащиеся садятся за компьютеры и подготавливают таблицу)

(Cлайд 4)

- В ячейке С1 будет храниться значение проходного балла – 13. Формула в ячейке Е3 вычисляет сумму баллов за три экзамена: В3+С3+D3 (или: =СУММ(В3:D3).

Формула в ячейке F3 задается с помощью условной функции.

Итак, открываем тетради, записываем число, тему урока.

(Учащиеся делают записи в тетради)

(Cлайд 5)

Объяснение нового материала.

(Cлайд 6-8)

Составить формулы для ЭТ с использованием условной функции.

1) Какое число больше?

2) Равна ли сумма двух чисел 12 (Да, нет)?

3) Оба числа положительные?

(Cлайд 9)

А теперь вернемся к нашей задаче. Давайте запишем формулу для ячейки F3.

(Слайд 10)

Условие, записанное с помощью логической операции И можно расшифровать так: сумма баллов (Е3)>=проходному баллу (С1) И оценка за экзамен по математике (В3)>3. Если условие выполняется, то в клетке F3 будет отображаться текст – ДА, в противном случае – НЕТ.

Для проходного балла в формуле используется абсолютный адрес $C$1, так как проходной балл является одинаковым и неизменным для всех абитуриентов. После заполнения третьей строки формулами, проведем копирование соответствующих формул в нижние строки. Формулы в столбцах Е и F после копирования будут выглядеть так:

(Слайд 11)

IV. Закрепление

Решить задачу путем построения ЭТ. Исходные данные для заполнения таблицы подобрать самостоятельно.

Задача. Таблица содержит следующие данные об учениках школы: фамилия, возраст и рост ученика. Сколько учеников могут заниматься в баскетбольной секции, если туда принимают детей с ростом не менее 160 см? Возраст не должен превышать 13 лет.

(Cлайд 12)

V. Итог урока. Выставление оценок.

VI. Дом. задание: § 21-22, с.119-123.

(Cлайд 13)

3.07.2014